Help & Guidance > Site/Forum Help

Log in issues

(1/4) > >>


Since a while I can't log into the play game log in page anymore. I've read that more people experience this problem and I've tried all solutions stated there. If I enter my username and password, it only refreshes and it doesn't give me a message. Even when I type in the wrong combination of Username/password it doesn't give a message either way. I am kinda lost now and I hope maybe I will get a solution here (: Or maybe it will help spread awareness that this happens.

I've tried:

Disabling proxy, which wasn't on.
Changed browsers
Cleared cookies
Used igocnito mode
Turned off firewall and anti-virus
Turned off adblocker

Hope to hear something soon! :D

Hai! Did you try reset your router or change your Wi-Fi?

Another fix could be opening the page on another device c:

Thanks for the fast replies !

I tried opening it on my phone and on another laptop, both didn't work. I think it has something to do with my WIFI. I live in a flat, so I don't have my own router, (I am a student). Or maybe I just can't find it, but my 'house' is fairly small so I am sure I don't have the router here, so I can't reset :(

What Wi-Fi you're using?


[0] Message Index

[#] Next page

Go to full version